笑话源码

发布时间:2017-02-15 来源: 幽默笑话 点击:

笑话源码篇一:巧妙查看服务端ASP源代码

巧妙查看服务端ASP源代码

——文/图KYO

看到题目也许会有人想起N年前的IDA和IDQ的查看ASP源代码的漏洞。但是这种肉鸡现在去哪里找呢?而我所说这个漏洞也是管理员的不安全配置所引起的。大家都知道用SERVER WIN2000做WEB服务器的时候,默认情况下应用程序的映射会有这几种,如下图:

看到了吗,stm为后缀名的文件也是被当作动态文本解析的。

*************************************************************** 这里插播个广告,黑友们请无视,只是为朋友的网站能被搜索引擎收录,多加点流量。 /retype/zoom/31f2b4a7b0717fd5360cdc16?pn=2&x=0&y=0&raww=512&rawh=384&o=png_6_0_0_135_535_576_432_892.979_1262.879&type=pic&aimh=360&md5sum=58ab411a3f71fdec49f246574d2b87d3&sign=9a95a6e9b9&zoom=&png=8846-17182&jpg=0-0" target="_blank">点此查看

看到了吗?也是服务端来解析的。

那么在当前文档内包含其它文件就可以查看ASP源代码了。:

相对于当前文档所在目录的路径:<!--#INCLUDE FILE="****.asp"-->

相对于某个虚拟目录的全路径:<!--#INCLUDE VIRTUAL="****.asp"-->

比如我编辑一个kyo2.stm内容是<!--#include file="conn.asp"-->然后直接请求,,接着查看源代码,那么conn.asp的内容就一览无余了,当然数据库路径就得到了。如下图:

其实还有很多用处,如下

返回文件的长度:

<!--#FSIZE FILE="****.asp"--><!--#FSIZE VIRTUAL="****.asp"-->

返回指定的文件最近一次被修改的时间:

<!--#FLASTMOD FILE="****.asp"--><!--#FLASTMOD VIRTUAL="****.asp"-->

执行一个应用程序,脚本,或shell 命令:

<!--#EXEC CGI="****.asp"--><!--#EXEC CMD="dir"-->

把这些存为stm,再直接请求后,可得到任意ASP文件的长度,最近一次被修改的时间,也可以执行程序,这些大家就自己实验吧!

*************************************************************** 这里插播个广告,黑友们请无视,只是为朋友的网站能被搜索引擎收录,多加点流量。 http://

返利网,淘你喜欢,淘宝返利,淘宝返现购物。

***************************************************************

说到最后,也许会有人说,这些怎么去利用啊。其实我也是偶然发现这个利用的地方的。有一次我在拿一个站的权限的时候,他的站是动力文章系统,大家可能都知道有上传漏洞,但是我所上传的cer cdx htr都不能被解析,最后我就传了一个stm文件,发现他的stm映射忘了删除。文件内容是<!--#include file="conn.asp"-->,直接请求这个stm文件,接着查看源代码,那么这个conn.asp就一览无余了。Conn.asp里面的数据库路径拿到后,就简单了,不用我说大家也知道怎么搞了。其实我说这些话的意思是,有些知识在你看来没有可利用的的地

方,但是真正碰到实际的问题,脑子里多存在一些这样的知识,那么会给你的入侵带来很大方便。

笑话源码篇二:买卖奇准 公式源码和图样

买卖奇准 公式源码和图样

抓涨停 抓龙头 短线抓涨停 大黑马 买卖奇准 选股公式

买卖奇准:CLOSE,colorred;

VAR1:=SUM(MAX(MA(HIGH-LOW,ABS(O-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),10);

VAR2:=HIGH-REF(HIGH,1);

VAR3:=REF(LOW,1)-LOW;

VAR4:=SUM(IF(VAR2>0 AND VAR2<VAR3,VAR2,0),13);

VAR5:=SUM(IF(VAR3>0 AND VAR3<VAR2,VAR3,0),13);

VAR6:=VAR4*100/VAR1;

VAR7:=VAR5*100/VAR1;

VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6),15);

VAR9:=(VAR8+REF(VAR8,15))/2;

A:=( VAR7>25 AND VAR6<25);

G:=MA(C,2),coloryellow;

D:=CROSS(C,G)*1000,colorred;

W:=CROSS(G,C)*1000,colorblue(来自:www.zhaoQt.NeT 蒲公桃花色综合影院摘:笑话源码);

E:=REF(INDEXC,1);

F:=SMA(MAX(INDEXC-E,0),3,1)/SMA(ABS(INDEXC-E),3,1);

VAR10:=F AND F<8;

VAR11:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

VAR12:=SMA(VAR11,3,1);

VAR13:=SMA(VAR12,3,1);

VAR14:=VAR13 AND VAR13<20;

MM:=A AND D AND VAR10 AND VAR14 ;

Ba1:=H;

Ga1:=MA(H,2);

Da1:=CROSS(Ba1,Ga1)*1000,colorred;

Wa1:=CROSS(Ga1,Ba1)*1000,colorblue;

/*DRAWTEXT(Wa1=1000,B*0.97,'卖★' ),coloryellow;*/

/*DRAWTEXT(Da1=1000 AND REF(CLOSE,1)<REF(ABF11,1) ,B*0.97,'买★'),colormagenta;*/ A30:=MA(C,30);

angleA30:=ATAN((A30/REF(A30,1)-1)*100)*99.66;

angle30:=angleA30>40 OR angleA30<-48;

A10:=MA(C,10);

angleA10:=ATAN((A10/REF(A10,1)-1)*100)*57.3;

angle10:=angleA10>20 OR angleA10<-25 AND CLOSE>MA(CLOSE,20) ;

A3010:=angle30 OR angle10;

aazt:=COUNT(CLOSE>O ,20)>0;

MA20黄:MA(C,20);

EMA1白:EMA(C,20);

SMA1绿:SMA(C,20,1);

DMA1红:DMA(C,VOL/CAPITAL);

DMR2:=CROSS(DMA1红,EMA1白);

DMR3:=CROSS(EMA1白,DMA1红);

DRAWGBK( W=1000 AND DMA1红>EMA1白 AND SMA1绿<EMA1白),colorcyan;

DRAWGBK( D=1000 AND DMA1红>EMA1白 AND SMA1绿<EMA1白),color0099FF;

DRAWTEXT(W=1000 AND DMA1红>EMA1白 AND SMA1绿<EMA1白,L,'-卖' ),colorcyan;

DRAWTEXT(D=1000 AND DMA1红>EMA1白 AND SMA1绿<EMA1白,L,'-买'),coloryellow;

DRAWGBK( W=999 AND aazt AND VAR14 AND DMA1红>EMA1白 AND SMA1绿<EMA1白),colorgreen; DRAWGBK( D=999 AND aazt AND VAR14 AND DMA1红>EMA1白 AND SMA1绿<EMA1白),colorred; DRAWTEXT(W=999 AND aazt AND DMA1红>EMA1白 AND SMA1绿<EMA1白 ,买卖奇准,'--卖全仓

' ),colorgreen;

DRAWTEXT(D=999 AND aazt AND DMA1红>EMA1白 AND SMA1绿<EMA1白,买卖奇准,'--买全仓'),colorred;

如有安不好或复制后不知道如何安到软件上的,可直接下载源码,下载后直接点安装就行了,本公式只适用同花顺软件。

买卖奇准 源码下载

笑话源码篇三:短信平台源代码

北信正通电信级短信平台

企信通平台

(MC-SMS)

产品说明书

联系人:戴先生

QQ:2247937678

目 录

一. 平台概述 ................................................................................................................................... 2

二. 平台构架 ................................................................................................................................... 5

2.1 网络构架 .......................................................................................... 错误!未定义书签。

2.2 系统构架 .......................................................................................... 错误!未定义书签。

三. 功能模块 ................................................................................................................................... 6

一. 平台概述

北信正通电信级短信平台MC-SMS,是一套全协议多链路跨平台可集群分布式的基于最底层通讯协议构架起来的一套电信级短信平台,与现有市场上的短信平台有着质的区别,应用于增值业务提供商(SP)、各级电信通道运营商及代理商、各种大中型电信通道应用商。北信正通电信级短信平台MC-SMS在通讯模块、数据接受和发送模块、数据处理模块等方面据具有强大的海量处理能力。平台支持现行运营商的所有短信通信协议(包括Cmpp3.0、Cmpp2.0、Sgip1.2、Sgip2.0、Isag\Ismp以及其他三方扩展协议),在通信方面采用多链路多队列集群方式,满足电信级用户的海量通信处理要求。在业务接口方面,我们也做到了多样,灵活,

简单,可靠,能满足客户各种业务需求,为第三方提了一个具有高度开放性,灵活性及可伸缩性的电信级应用解决方案。

北信正通电信级短信平台MC-SMS具有以下特点:

1、全协议:北信正通电信级短信平台MC-SMS支持中国移动CMPP协议,支持中国联通SGIP协议,支持中国电信SMGP协议,支持原中国网通CNGP协议,支持国际通信协议SMPP协议,同时,平台还支持新电信C网接入协议暨《中国电信综合业务接入网关_ISAG_开放接口协议》,另外,还支持多种自定义的Socket、Http及WebService等三方自定义协议;

2、多链路:北信正通电信级短信平台采用多链路(Multi-Homing)方式接入各运营商网关,如一条链路出现故障时,将自动切换到其他链路;并在一条链路流量大时自动分配其余流量到其他的链路上,链路数以及链路处理机制的参数都是可以配置和调节的;

3、多队列:所有的数据都是采用独立内存队列缓冲设计,这样能够最大限度的发挥内存的极致速度,加上可扩展的滑动窗口机制,能从容应对突发的爆发式信息的处理,而不至于系统有丝毫呆滞的感觉;同时也利于系统的分布式部署和复杂业务的扩展,同时又能为彻底解决系统处理的速度瓶颈提供支持;

4、极致高效:所有协议都是基于最底层的Socket通讯实现,因此可以完全摒除冗余数据,使数据处理和传递效率得到极致发挥,充分发挥服务器Cpu、内存、硬盘之间的作用和效率。实验环境下,单机能达到1500条上行/每秒、2000条下行/每秒的速度,当然,下行是可以扩展的,如果采取分布式的扩展部署,下行效率将会进一步提高;

5、安全稳定:系统是基于成熟底层API、成熟Socket框架、成熟通讯队列处理框架、成熟数据传递机制上搭建起来的,监控模块能无缝隙监控各模块运行工作状况,会及时处理异常情况,设计理念和日本成人电影均源自于中国移动的短信网关系统,在应用上经受了月流量5亿,连续36个月稳定运行的大考验;

6、维护简单:完全可视化的配置界面,配置接入参数和调配性能参数,都是通过可视化界面操作,清晰简单快捷;很多业务开发功能通过后台配置就能完成;基于平台的复杂业务开发完全基于数据库脚本,有现成模板可以套用;基于接口模式的开发也是脚本级的开发,均是非常的简单,一般没有经验的计算机工程师经过1-3天的培训均能胜任;

7、构架清晰:系统的各种功能模块耦合度非常低,而单一模块间的内聚性又非常高,整个系统构架非常清晰,因而,整个系统的可扩展性非常强。一般来说,另外一套完全不同领域的业务系统,均能在此系统的骨架脉络上搭建融合起来;

8、服务体贴:我们会对所有源代码的功能、编译、调试进行详细的培训,并详细讲解

基于此平台的维护和扩展开发。

二. 平台构架 系统流程图:

图 2.0.0

相关热词搜索:源码 笑话 麻花笑话源码 经典笑话源码

热点文章阅读

版权所有 蒲公桃花色综合影院摘 www.zhaoqt.net